Is my device compatible?

To use our Dash and Dot, you need to use a compatible device with Bluetooth 4.0/LE.

We officially support the devices listed here

Also note the follow:

Any device meeting the criteria of BTLE 4.0  will be able to work with our apps. However we have not text devices not listed on our compatibility support page. If they are not on the list there may be UI or Functional issues. 

You are free to download and try any of our apps that meet the minimum requirements. 

Once we have fully tested a new device and passes all our test cases we will add it to the list. 

Did you find this article helpful?